logo
Bienvenido visitante. Para activar todas las funcionalidades, por favor Iniciar sesión o Registrarse.

Aviso

Icon
Error

Opciones
Ver
Ir a la última publicación Ir al primero no leído
Offline tasrock  
#1 Publicado : sábado, 18 de noviembre de 2017 07:18:47 p. m.(UTC)
tasrock

Posición: Newbie

Grupos: Registered
Registrado: 18/11/2017(UTC)
Mensajes: 3

Can you provide a list of possible command line options? I am hoping to find that AllWemo can obtain the status of a Wemo switch from command line instead of just sending actions.

Thanks,
Travis
Offline Enrique  
#2 Publicado : lunes, 11 de diciembre de 2017 12:49:55 p. m.(UTC)
Enrique

Posición: Administration

Grupos: Administrators
Registrado: 27/09/2010(UTC)
Mensajes: 25
Hombre
México

Fue agradecido: 1 vez/veces in 1 publicación(es).
The newest version (3.22) has an embedded web server.
You can activate it and ask for the status of a device:

To retrieve the device status you can send:
http://localhost:8099/?Sta=192.168.0.120
Setting Sta to the device ip you want to check

To turn the device on or off you can send:

http://localhost:8099/?Manda=1&Dev=192.168.0.120&Acc=Off
where Acc can be On or Off
Dev is the device ip address


Offline tasrock  
#3 Publicado : domingo, 17 de diciembre de 2017 12:54:14 p. m.(UTC)
tasrock

Posición: Newbie

Grupos: Registered
Registrado: 18/11/2017(UTC)
Mensajes: 3

Thanks for the information. I have upgraded (3.27.6557.24302) but when I have the webserver enabled I get an error on AllWemo program startup of "Access Denied". I have tried changing the port number in case of conflict. The only thing take makes the error go away is to turn off the webserver option. Unfortunately the command line options that I had been using no longer seem to work so my system is now broken.
Offline tasrock  
#4 Publicado : domingo, 17 de diciembre de 2017 03:35:05 p. m.(UTC)
tasrock

Posición: Newbie

Grupos: Registered
Registrado: 18/11/2017(UTC)
Mensajes: 3

I didn't realize that the path changed. I updated the path to AllWemo.exe and my system is at least back. I checked the Windows firewall and all looks good there regarding the webserver. Still not working.
Offline Enrique  
#5 Publicado : jueves, 21 de diciembre de 2017 11:54:52 a. m.(UTC)
Enrique

Posición: Administration

Grupos: Administrators
Registrado: 27/09/2010(UTC)
Mensajes: 25
Hombre
México

Fue agradecido: 1 vez/veces in 1 publicación(es).
Hi, to enable the web server, you need to run the app with admin privileges
Usuarios navegando este tema
Salto de foro  
No puedes iniciar nuevos temas en este foro.
No puedes responder a temas en este foro.
No puedes eliminar sus temas en este foro.
No puedes editar sus temas en este foro.
No puedes crear encuestas en este foro.
No puedes votar las encuestas en este foro.