Welcome Guest! To enable all features please Login or Register.



Go to last post Go to first unread
Offline tasrock  
#1 Posted : Sunday, January 31, 2021 9:08:56 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 11/18/2017(UTC)
Posts: 4

On my old PC I was running 3.27.6557.24302. I wrote a VB.net program that called "AllWemo.exe -name:PorchLight -action:on" and similar for other switches from shell based on my local sunrise sunset times that I get from the web. I wasn't able to find the old version installation file so I downloaded the latest version from your website. I have run into several problems trying to implement this system with the latest version.

The new version has the UAC popup so when my program calls it from shell it does not run. It just sits there waiting on someone to click yes.
So I tried to rewrite my code with this:

Dim oPro As New Process
With oPro
.StartInfo.UseShellExecute = True
.StartInfo.Arguments = Arguments
.StartInfo.FileName = WemoExecutablePath
.StartInfo.Verb = "runas"
End With

The same UAC issue occurs so apparently I'm going down the wrong path.

I tried enabling the web server in AllWemo. I tried it with and without user/pass fields filled in. I tried it with and without Accept usr and pwd in url option checked. I tried it with my firewall enabled and disabled. I tried a different server port. I always get "This site can’t be reached" "localhost refused to connect." "ERR_CONNECTION_REFUSED" on my Chrome browser. Same error for Edge. Similar for IE. I think I ran into this same problem when I tried to update my AllWemo previously hence why I haven't updated in so long.
Here is a short list of some URLs that I have tried:
http://localhost:8099/ -> refused
http://localhost:8099/?usr=username&pwd=password -> refused
http://localhost:8099/?Sta= -> refused
http://localhost:8099/?Manda=1&Dev= -> refused

Can you provide me with some troubleshooting hints with either the web server or calling the executable from VB.net? Maybe a VB.net example for calling the program programmatically with the latest version would be helpful for others? I'm up for whatever.

I know that the Wemo app has this same base functionality, but my mobile app hasn't worked in years even through new phones.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.